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Overview

I
Discover how to find and fix threading errors using the Intel® Inspector XE and the nqueens fortran
Fortran sample application.

About This This tutorial demonstrates an end-to-end workflow you can ultimately apply to your
Tutorial own applications:
1. Build an application to produce an optimal inspection result.
2. Inspect an application to find threading errors.
3. Edit application code to fix the threading errors.
4. Investigate threading errors using interactive debugging.
5. Rebuild and reinspect the application.
Estimated 10-15 minutes.
Duration
Learning After you complete this tutorial, you should be able to:
Objectives

List the steps to find and fix threading errors using the Intel Inspector XE.
Define key Intel Inspector XE terms.

Identify compiler/linker options that produce the most accurate and complete
analysis results.

Run threading error analyses.

Influence analysis scope and running time.

Navigate among windows in the Intel Inspector XE results.

Display a prioritized to-do list for fixing errors.

Access help for fixing specific errors.

Access source code to fix errors.

Launch an interactive debugging session to investigate problems more deeply.

More Resources

The concepts and procedures in this tutorial apply regardless of programming
language; however, a similar tutorial using a sample application in another
programming language may be available at http://software.intel.com/en-us/articles/
intel-software-product-tutorials/. This site also offers tutorials for other Intel®
products and a printable version (PDF) of tutorials.

In addition, you can find more resources at http://software.intel.com/en-us/articles/
intel-parallel-studio-xe/.
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Navigation Quick Start

@ Intel® Inspector XE is a dynamic memory and threading error checking tool for users developing serial
and multithreaded applications on Windows* and Linux* operating systems. You can also use the Intel
Inspector XE to visualize and manage static analysis results created by Intel® compilers in various suite
products.

Intel Inspector XE Access

To access the Intel Inspector XE in the Visual Studio* IDE: From the Windows* Start menu, choose All
Programs > Intel Parallel Studio XE 2013 > Parallel Studio XE 2013 with [VS2008 | VS2010].

To access the Standalone Intel Inspector XE GUI, do one of the following:

e From the Windows* Start menu, choose All Programs > Intel Parallel Studio XE 2013 > Intel
Inspector XE 2013.

e From the Windows* Start menu, choose All Programs > Intel Parallel Studio XE 2013 > Command
Prompt > Parallel Studio XE with Intel Compiler > IA-32 Visual Studio [2008 | 2010] mode to
set up your environment, then type inspxe-gui in the Command Prompt window.

Intel Inspector X€/Visual Studio* IDE Integration

Ede Ede MNiew Progect fuild [ebog Tesm Dpta Jooks Arghitecture Tesi Apshoe Window Help
Pod= = 5 el % = - LIS ¥ Debug ~| | Win22 B T IR A RN
Bo-lap | A2

i o0 i o 2 Seluticn Explorer
'“'" Detect Deadlocks and Data Races Intel Inspector XE 2013

& Target Anabpsks Type | B Collection Log m

Problemn i | Fivers Sariv T

A Solution ‘ngueens_Tortran’ (3 peo
r n Inspeicied XE Regulis
& o memery siuel

L I = o Problem  Sources T T — A &l o0m2
- . B o0imiz
3 - a.F} thresding rtust.ece = Mot fived Eror 2 inemds) st theeading_issses
H [T e e |- e Froblom AR @ ooz
Data race  ngueers theesding i threading, mouesexe P Mot fued Clata race 2 Aerms) E A2

2 B memneey imsues

Datsrace  noueens_thresding threading irsues.ece > Mot fived
L wt i ik L Sowrce 2
Hesder Fes

P = ] Data race  ngueers_theesding.f30 thresding_ntueseve B Mot fued

nequeens,_threading £30 2 Memis) q
Chata race ngueerd_thisbshngl . thisading diueieof Fr Mot fmed 1 —d Fetource Files
Datarace  ngueerds theesdingd . threading souesexe P Mot fued 4 3 Source Files
" threading rsues.ee 2 ez} =

Skale
Mt freed 2 Awrrg)
Luppressed
Mot suppressed

Investagated
Mot irrcestagated 2demis) =

B threading_kaues
] Heades Fles
23 Resource Files
"3 Seiree Files

2 demis)

10 1ofs b |4 | Cade locations: Data race ¥
Description Source Functicn Medule = N =
i Woorkes Theesd F1 [200) (2

Resd nejueens thresding 90:135 NQUEENS ip SETQUEEN thresding Bsuesexe

taCis thresding issues.exe 'BOTEEN
cirs hresding_issues.exe ! BQUECS

nqueens_thresding f0:143 NOUEENS ip SETQUEEN thresding_ssues exe
column i3 ok, set the gutes threading_issues.exe !B

paemns (row] = oo ehenpding | itisc s i




1 Getting Started Tutorial: Analyzing Threading Errors

ﬂ 'ﬁ The menu, toolbar, and Solution Explorer offer different ways to perform many of
- - W the same functions.

) Use the Tools > Intel Inspector XE 2013 menu to create dynamic
o analysis results, compare results, and import result archive files and
results from other Intel® error-detection products.

ﬁ- Use the Intel Inspector XE toolbar to open the Getting Started page,
- create dynamic analysis results, compare results, and configure projects.
,ﬁ Solution Explorer context menus (right-click to open):

¢ Use the Intel Inspector XE 2013 menu on the Solution Explorer
project context menu to create dynamic analysis results and configure
projects.

e Use the context menu on a result in the Inspector XE Results folder
to open results, export result archive files, create dynamic analysis
results, and manage results.

B Use the Intel Inspector XE result tabs to manage result data.

]

Standalone Intel Inspector XE GUI
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i & The menu, toolbar, and Project Navigator offer different ways to perform many of
- the same functions.
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Navigation Quick Start 1

@ Use the menu to create projects and dynamic analysis results, import

- result archive files and results from other Intel® error-detection products,
open projects and results, compare results, configure projects, set
various options, and access the Getting Started page and Help.

Use the toolbar to open the Getting Started page; create, configure, and
open projects; create dynamic analysis results; and open and compare
results.

@ Use the Project Navigator:

e Tree to see a hierarchical view of your projects and results based on
the directory where the opened project resides.

¢ Context menus (right-click to open) to perform functions available
from the menu and toolbar plus delete or rename a selected project or
result, close all opened results, and copy various directory paths to the
system clipboard.

"ﬁ Use result tabs to view and manage result data.

Intel Inspector XE Result Tabs
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G Use result tab names to distinguish among results.

Click buttons on the navigation toolbar to change window views.
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10

12

Use window panes to view and manage result data.

Click ¥ buttons to display help pages that describe how to use window panes.

Drag window pane borders to resize window panes.

[ 4
Click ===, 1 =1, _, and _ controls to show/hide window panes.

Click window pane data controls to adjust result data within the pane (and possibly in adjacent
panes).

Data column headers - Drag to reposition the data column; drag the left or right border to
resize the data column; click to sort results in ascending or descending order by column data.

Use title bars to identify window panes.

Right-click data in window panes to display context menus that provide access to key
capabilities.



Analyzing Threading Errors

@ There are many ways to take advantage of the power and flexibility of the Intel Inspector XE. The
following workflow, which shows how to find and fix threading errors in parallel programs, is one way to help
maximize your productivity as quickly as possible.

One-time / Optional

'

Choose /Create Configure
project project

Set up

Run Configure
dynamic dynamic
analysis analysis

& Launch analysis in
a Rﬁg}‘;‘:ﬂ]“ comjunction with debugger to
pPp stop at problem(s) of interesE

f

Collect result

Choose
problam

Investigate result

Examine
application
state

Interpret
result data/f
Resolve issue

Step 1: Unpack Do one of the following:
and set up . . . i . i
sample for e In the V|sual Stud|o* IDE: Choo;e a project, verify settings, and build an
analysis application to inspect for threading errors.
¢ In the Standalone Intel Inspector XE GUI: Build an application to inspect for
threading errors and create a new project.
Step 2: Collect » Configure a threading error analysis.
result e Run the threading error analysis on the application.
Step 3: * Choose a problem in the analysis result.
Investigate  Interpret the result data.
result e Resolve the issue.
¢ Investigate another problem using interactive debugging.
Step 4: Check Rebuild the application and rerun the threading error analysis.
your work

Visual Studio* IDE: Choose Project and Build Application

13



2 Getting Started Tutorial: Analyzing Threading Errors

1
Follow these steps only if you are using the Intel Inspector XE plug-in to the Visual Studio* IDE to
complete this tutorial.

To create an application the Intel Inspector XE can inspect for threading errors:

e Get software tools.

e Open a Visual Studio* solution.

e Choose a startup project.

o Verify optimal compiler/linker settings.

e Verify the application is set to build in debug mode.
e Build and test the application.

Get Software Tools

You need the following tools to try tutorial steps yourself using the nqueens fortran sample application:

e Intel Inspector XE, including sample applications
e .zip file extraction utility
e Supported compiler (see Release Notes for more information)

Acquire the Intel Inspector XE

If you do not already have access to the Intel Inspector XE, you can download an evaluation copy from
http://software.intel.com/en-us/articles/intel-software-evaluation-center/.

Install and Set Up the Intel Inspector XE Sample Applications

1. Copy the nqueens fortran.zip file from the <install-dir>\samples\<locale>\Fortran
directory to a writable directory or share on your system. The default <install-dir> is C:\Program
Files (x86)\Intel\Inspector XE 2013\ (on certain systems, instead of Program Files (x86),
the directory name is Program Files).

2. Extract the sample from the .zip file.

ﬂ e Samples are non-deterministic. Your screens may vary from the screen captures shown throughout
this tutorial.
e Samples are designed only to illustrate the Intel Inspector XE features; they do not represent best
practices for creating code.

Open a Visual Studio* Solution

1. Choose File > Open > Project/Solution.
2. Inthe Open Project dialog box, open the nqueens fortran\nqueens fortran.sln file to display
the nqueens_fortran solution in the Solution Explorer.

NOTE The nqueens fortran.sln solution was created using the Visual Studio* 2008 IDE. If the
Visual Studio* conversion wizard appears, follow the steps to convert the solution to run on your
installed version of the Visual Studio* IDE.

14
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Choose a Startup Project

If the threading_issues project is not the startup project (project typeface in the Solution Explorer is not
bold),

1. Right-click the threading_issues project in the Solution Explorer.
2. Choose Set as StartUp Project, which changes the project typeface to bold.

Verify Optimal Compiler/Linker Settings
You can use the Intel® Inspector XE to analyze:
e Memory errors in debug and release modes of:

e C++ binaries - The Intel Inspector XE can analyze native code in native and mixed native/managed
binaries.

e Fortran binaries - The Intel Inspector XE can analyze native code in native binaries.
e Threading errors in debug and release modes of:

e C++ binaries - The Intel Inspector XE can analyze native and managed code in native, managed, and
mixed native/managed binaries.
e Fortran binaries - The Intel Inspector XE can analyze native code in native binaries.

Applications compiled/linked in debug mode using the following settings produce the most accurate and
complete analysis results.
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2 Getting Started Tutorial: Analyzing Threading Errors

Compiler/Linker
Property

Correct C/C++
Setting

Correct Fortran
Setting

Impact If Not Set
Correctly

Debug information

Enabled (/zi or /z1)

Enabled (/debug: full)

Missing file/line
information

Optimization

Disabled (/0d)

Disabled (/0d)

Incorrect file/line
information

Dynamic runtime library

Selected (/MD or /MDd)

Selected (/1ibs:d11/
threads or 1ibs:d11/
threads/dbglibs )

False positives or
missing code locations

Basic runtime error
checks

Disabled (do not use /
RTC; Default option in

None (/check:none)

False positives

Visual Studio* IDE)

hWNR

Right-click the threading_issues project in the Solution Explorer.

Choose Properties to display the Property Pages dialog box.

Verify the Configuration drop-down list is set to Debug or Active(Debug).
In the left pane, choose Configuration Properties > Fortran.

e Choose Debugging and verify the Debug Information Format field is set to Full (/debug:full).

e Choose Optimization and verify the Optimization field is set to Disable (/0d).

e Choose Libraries and verify the Runtime Library field is set to Multithread DLL (/libs:dll/
threads) or Debug Multithread DLL (libs:dll/threads/dbglibs).

e Choose Run-time and verify the Runtime Error Checking field is set to None (/check:none).

In the left pane, choose Configuration Properties > Linker > Debugging and verify the Generate

Debug Info field is set to Yes (/DEBUG).

Verify the Application is Set to Build in Debug Mode

1.

2.
3.
4.

Click the Configuration Manager button.

Verify the Active solution configuration drop-down list is set to Debug.
Click the Close button to close the Configuration Manager dialog box.
Click the OK button to close the Property Pages dialog box.

Build and Test the Application

1. Choose Build > Project Only > Build Only threading_issues to build a single project in the
solution.
2. Check the messages in the Output window to confirm the build succeeded.
3. Choose Debug > Start Without Debugging to test the application.
4. If the Visual Studio* IDE responds any projects are out of date, click No.
5. Check for non-deterministic application output (that also varies by number of cores) similar to the
following:
Usage: threading issues.exe boardSize
Using default size of 10
Starting nqueens solver for size 10 with 2 thread(s)
Number of solutions: 1344
Correct result!
Calculations took 31 ms.
Press any key to continue...
Key Terms

False positive

16
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Standalone GUI: Build Application and Create New Project

I
Follow these steps only if you are using the Standalone Intel Inspector XE GUI to complete this tutorial.
To create an application the Intel Inspector XE can inspect for threading errors:

e Get software tools.

e Verify optimal compiler/linker settings.

¢ Build the application.

e Verify the application runs outside the Intel Inspector XE.
e Open the Standalone Intel Inspector XE GUI.

e Create a new project.

Get Software Tools

You need the following tools to try tutorial steps yourself using the nqueens fortran sample application:

e Intel Inspector XE , including sample applications
e .zip file extraction utility
e Supported compiler (see Release Notes for more information)

Acquire the Intel Inspector XE

If you do not already have access to the Intel Inspector XE, you can download an evaluation copy from
http://software.intel.com/en-us/articles/intel-software-evaluation-center/.

Install and Set Up the Intel Inspector XE Sample Applications

1. Copy the nqueens fortran.zip file from the <install-dir>\samples\<locale>\Fortran\
directory to a writable directory or share on your system. The default <install-dir>is C:\Program
Files\Intel (x86)\Inspector 2013\ (on certain systems, instead of Program Files (x86), the
directory name is Program Files).

2. Extract the sample from the . zip file to create the nqueens fortran directory.

e Samples are non-deterministic. Your screens may vary from the screen captures shown throughout
this tutorial.
e Samples are designed only to illustrate the Intel Inspector XE features; they do not represent best
practices for creating code.

Verify Optimal Compiler/Linker Settings
You can use the Intel® Inspector XE to analyze:

e Memory errors in debug and release modes of:

e C++ binaries - The Intel Inspector XE can analyze native code in native and mixed native/managed
binaries.

e Fortran binaries - The Intel Inspector XE can analyze native code in native binaries.
e Threading errors in debug and release modes of:

e C++ binaries - The Intel Inspector XE can analyze native and managed code in native, managed, and
mixed native/managed binaries.

e Fortran binaries - The Intel Inspector XE can analyze native code in native binaries.

Applications compiled/linked in debug mode using the following settings produce the most accurate and
complete analysis results.

17
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Compiler/Linker
Property

Correct C/C++
Setting

Correct Fortran
Setting

Impact If Not Set
Correctly

Debug information

Enabled (/zi or /z1)

Enabled (/debug: full)

Missing file/line
information

Optimization

Disabled (/0d)

Disabled (/0d)

Incorrect file/line
information

Dynamic runtime library

Selected (/MD or /MDd)

Selected (/1ibs:d11/
threads or 1ibs:d11/
threads/dbglibs )

False positives or
missing code locations

Basic runtime error
checks

Disabled (do not use /
RTC; Default option in
Visual Studio* IDE)

None (/check:none)

False positives

Build the Application

1. From the Windows* Start menu, choose All Programs > Intel Parallel Studio XE 2013 >
Command Prompt > Parallel Studio XE with Intel Compiler > IA-32 Visual Studio [2008 |
2010] mode to set up your environment.

2. Change directory to the nqueens fortran directory in its unzipped location.

3. If you chose IA-32 Visual Studio 2008 or IA-32 Visual Studio 2010 mode, type devenv
nqueens_fortran.sln to convert the nqueens fortran.sln solution. When conversion is complete,
close the Visual Studio* IDE.

4. Type devenv nqueens_ fortran.sln /Build to build all projects in the solution.

NOTE Do not be concerned if you see a Build: 2 succeeded,
analysis build errors.

1 failed message because of static

Verify the Application Runs Outside the Intel Inspector XE

1. Change directory to threading issues\Debug\.

2. Type threading issues.exe to execute the application.
3. Check for non-deterministic application output (that also varies by number of cores) similar to the

following:

Usage: threading issues.exe boardSize
Using default size of 10
Starting nqueens solver for size 10 with 2 thread(s)

Number of solutions:

Incorrect result!

1333

Calculations took 31 ms.

Open the Standalone Intel Inspector XE GUI
From the Windows* Start menu, choose All Programs > Intel Parallel Studio XE 2013 > Intel

Inspector XE 2013.

Create a New Project

1. Choose File > New > Project... to display a dialog box similar to the following:

18




Analyzing Threading Errors 2

Create a Project M

Project name: |

Location: C:\Jsers\Documents\Inspector \Projects

In the Project name field, type threading issues. Then click the Create project button to create a
config.inspxeproj file in the \Inspector\Projects\threading issues\ directory (default
location) and display a dialog box similar to the following:

threading_issues - Project Properties =
Target | Suppressions Binary/Symbol Search Sowrce Search
Launch Application

specify and configure the application executable (target) to analyze. Press F1 for more details.

€ Mo application executable (target) fie specified.Click the Project Properties button to choose and configure the target.

Application: * | Browse..

|
Application parameters: Modify..
Working directory: Browse..

[¥] Inherit system environment variables

User-defined envircnment vanables:
| Modify... |

Microsoft® runtime emvironment: | Auto >

@ Store result in the project directory:  C\Users) DocumentsiInspector\Projects\threading_issues

Store result in (and create link file to) ancther directory
ChUsers\Documents\Inspector\Projects\threading_issues Browse..

Result location:
ChAUsers\Documents\inspector Projects\threading_issues\r@ @ @&{ et}

i~ Advanced
Do not apply suppressions -

m [ Cancel ]

Suppressions:

Click the Browse button next to the Application field and select the nqueens fortran

\threading issues\Debug\threading issues.exe application. Notice the Intel Inspector XE
autofills the project Working directory field for you. Then click the OK button to return to the
Welcome page, where the name of the opened project displays in the title bar and in the Project
Navigator pane. (If necessary, choose View > Project Navigator to display the Project Navigator.)

19



2 Getting Started Tutorial: Analyzing Threading Errors

Key Terms
False positive

Configure Analysis
I

3 Intel Inspector XE offers a range of preset threading analysis types to help you control analysis scope
and cost. The analysis type with the narrowest scope minimizes the load on the system and the time and
resources required to perform the analysis; however, it detects the narrowest set of errors and provides
minimal details. The analysis type with the widest scope maximizes the load on the system and the time and
resources required to perform the analysis; however, it detects the widest set of errors and provides context
and the maximum amount of detail for those errors.

To configure a threading error analysis, choose a threading analysis type.

Choose Threading Error Analysis Type
To display an Analysis Type window similar to the following:

e From the Visual Studio* menu, choose Tools > Intel Inspector XE 2013 > New Analysis....
e From the Standalone Intel Inspector XE GUI menu, choose File > New > Analysis....

Fl-lz '|'|EwHaeﬁ:|
‘H kSO He b

Mew Inspector Result <

Intel Inspector XE 2013

1=l Detect Deadlocks | m

—?ga 1-50 ] = et Desdlocks and Data Races

Alke- 160 Lecate Deadiocks and Data Races > l"IIIl- il
Threading Emor Anslysis = :

2 Anabyzis Time Choerhead Memiory Chrerhiead

Detect Desdiocks amd Data Races Copy

Wedium scope threadng enmar snalysis type. Increases the load on the system and the time and rescurces required ta
perform analyiss, Press F1 fos rvoes detas,

Terminate on deadlock 4

Stack frame depth: |1 =l

Details

Detect lock herarchy vielstions and deadlocks: Yes 5

Terminate on desdiock: Mo

Cross-theead stack access detection: Hide probdems/Show warnings

Stack frame depthc 1

Deetect data races Wes

Memaory sccess byte granulanity: 4 bytes

Dietect dats races on stack sccesses: Mo

Remove duplicates: e
Defer mermony check: Wes

Sawe stack on first acoess: Mo Command Line...

NOTE Your screen includes interactive debugging options if you are working in the Visual Studio* IDE.
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Analyzing Threading Errors 2

1 Use the Navigation toolbar to navigate among the Intel Inspector XE windows. The buttons on
the toolbar vary depending on the displayed window.

2 Use the Analysis Type drop-down list to choose an analysis type category: Memory Error
Analysis, Threading Error Analysis, or Custom Analysis Types.

Choose the Threading Error Analysis type category.

NOTE This tutorial covers threading error analysis types, which you can use to search for
data race, deadlock, lock hierarchy violation, and cross-thread stack access errors. Use
memory error analysis types to search for resource leak, incorrect memcpy call, invalid
deallocation, invalid memory access, invalid partial memory access, memory growth,
memory leak, memory not deallocated, mismatched allocation/deallocation, missing
allocation, uninitialized memory access, and uninitialized partial memory access errors.

3 Use the configuration slider to choose a preset analysis type and the corresponding gauges to
assess the cost of that choice. The preset analysis type at the top of the slider has the
narrowest scope; the preset analysis type at the bottom has the widest.

Choose the Detect Deadlocks and Data Races preset analysis type.

The Analysis Time Overhead gauge helps you quickly estimate the time it may take to collect
a result using this preset analysis type. Time is expressed in relation to normal application
execution time. For example, 10x - 40x is 10 to 40 times longer than normal application
execution time. If normal application execution time is 5 seconds, estimated collection time is
50 to 200 seconds.

The Memory Overhead gauge helps you quickly estimate the memory the Intel Inspector XE
may consume to detect errors using this preset analysis type. Memory is expressed in blue-
filled bars.

u NOTE The gauge does not show memory used by the running application during analysis.

4 Use the checkbox(es) and drop-down list(s) to fine-tune some, but not all, preset analysis type
settings.

NOTE If you need to fine-tune more analysis type settings, you can choose another
analysis type or create a custom analysis type.

5 Use the Details region to view all current settings for this analysis type.

6 Use the Command toolbar to control analysis runs and perform other functions. For example,
use the Project Properties button to display the Project Properties dialog box, where you
can change the default result directory location, set parameters to potentially speed up
analysis, and perform other project configuration functions.

If you experimented with various settings, make sure you choose the Detect Deadlocks and Data Races
preset analysis type (and ensure your settings match the image above) before proceeding.

Key Terms

Analysis

21



2 Getting Started Tutorial: Analyzing Threading Errors

Run Analysis

m To find threading errors that may need fixing, run a threading error analysis.

Run Threading Error Analysis
Click the Start button on the Analysis Type window and the Intel Inspector XE:

e Executes the threading issues.exe application.
¢ Identifies threading errors that may need handling.
e Collects the result in a directory in the:

e nqueens_ fortran\threading issues\My Inspector XE Results - threading issues\
directory (Visual Studio* IDE)
e Inspector\Projects\threading issues\ directory (Standalone Intel Inspector XE GUI)
¢ Finalizes the result.

During analysis, the Intel Inspector XE displays a Collection Log window similar to the following:

File~ Ve Help
Y =R g SR X
ropotiz < L ®

Collecting Data... Intel Inspector XE 2013

& Target Anahyiss Type B(nﬂﬁlhnlng *  Sumeary

This mary indicate cne or morne bugs in your spplication. Setting the Jotel[R)
Inspector XE 2013 to detect data races on steck accesses and runniff S ither
analysis may help you locate these and other bugs.

Target finished running

Targ“ finashued funAing

Finalizing data...

Iritel® Inspector XE 2003 4 using debug snfermstion fram binery files ta
comvert symbal nfermation to filensmes and bine numbers, pedonming
duplcate elirmanation, and forming probiem sets.

Elapsed time since collection start (0:00-10
Memorny used by collector process and target application: 0 Mb

Hide details
Theead Name /10 1n System Call oo o0 Activity
P ‘Worbcer TheeadMe 1X3d5d
Fuiird s 40
3240 Yes 1261532

To redirect application oirtpat to here
o b B i batot desanaten sotbi

Elapsaed time: O0:00:10

1 The result name appears in the tab. Here, the name of the result is r000ti2, where

e r = constant
e 000 = next available number
e ti = threading error analysis type
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Analyzing Threading Errors 2

e 2 = preset analysis type of medium scope

NOTE Intel Inspector XE also offers a pointer to the result in the Solution Explorer
(Visual Studio* IDE) and Project Navigator (standalone GUI).

2 The Collection Log pane shows analysis progress and milestones.

Notice you can start to manage results before analysis (collection and finalization) is complete
by clicking the Summary button; however, this tutorial does not cover handling issues before

analysis is complete.

NOTE This tutorial explains how to run an analysis from the Intel Inspector XE GUI. You can also use
the Intel Inspector XE command-line interface (inspxe-cl command) to run an analysis.

The Summary window automatically displays after analysis completes successfully.

Key Terms

e Analysis
e (ollection
e Finalization

Choose Problem

I~

i To start exploring a detected threading error:

¢ Understand Summary window panes.
e Choose a problem.

Understand Summary Window Panes
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2 Getting Started Tutorial: Analyzing Threading Errors

File View Help

H | B0 bW

T
Detect Deadlocks and Data Races Intel EHSDE“GF XE 2013

® Target|  Ansiys Tpe [ . Caliection oo | [N ()

[— :
D o Prablem Saurces Medules State Severity

arl I Datarace  nqueens_threading 90 threading mrues.eoe ' Mew Error
Dots race  ngueens_thresding 90 threadeng_issues.exe R New Problem
Data race

| Source
| ngqueens_threading.f30

Haodule

thresdng_ e, e

State
Mew

10f8 b [A1]

Source Function Maodule

nqueens_theeading 0143 NQUEENS ip SETQUEEN threading issuss.cor
! coluen is ok, =et the gqueen threading iasnes.exe! BT
'1cl quesns (row) = cal
gaesns(rov) = eol

L (Z0w == JLTE) ';:'.i:

nqueens_theeading.f20:143 MOQUEENS_ ip_SETQUEEN threading_istues. exe

is ok, ST che quessn chrsading issaes,sxe!l

ng_issues.exc!l

q The Summary window is the starting point for managing result data. It groups problems into
- problem sets and then prioritizes the problem sets by severity and size.

2 Think of the Problems pane as a to-do list. Start at the top and work your way down. Try
- viewing the problems in various problem sets by clicking the corresponding [ icon.

3 The Code Locations pane shows the code location summary, surrounding source code snippet,
- call stack, and thread and timeline information for all code locations in one or all occurrences of
the problem(s) highlighted in the Problems pane.

|41l 10f8 b [41]]

Try viewing information for different occurrences of the highlighted problem by clicking the IE
or E controls, or clicking the All button.

Choose a Problem

When you are finished experimenting:

1. Click the # icon for both Data race problem sets.

2. Double-click the data row for one of the Data race problems at line 148 in the
nqueens_threading.£90 file to display the Sources window, which provides more visibility into the
cause of the error.

Key Terms

e Code location
e Problem
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e Problem set
e Result

Interpret Result Data

In*

& To determine the cause of the detected threading error:

e Interpret Sources window pane tabs.
e Access more information on interpreting and resolving problems.

Interpret Sources Window Pane Tabs

File View Help

H s BT bW

Intel Inspector XE

Anahysks Type || I Colle

Il Catt stack] 8

thraading jssues. seNOUEENS ip SETOUEEN - naussns.

if [row == size] then
'uncosment the stomdc to fiw a race condition on the nrOfSolutions varishls
11§0ME RTOMIC
nrOfSolntions = ncOfSoluticns + 1
elag
! oy oo CL11 neXt Dow
o i=1,0i2e
teall secQueen (Lol _guesns, Dow+l, 1)
call sevQuesn (gaeens, rowsl, i)
&nd da

| cat stack
threadang_issues. exeHQUEENS_ip_SETQUEEN - noueens |
if [row == 3ize) then threading_issues, eve NQUEENS ip_SETQUEEN - ngueens
Tuncosment the atomic to fix & race conditicn on the neQfSolutions variable
11G0MF ATOMIC
nrOfSoluticns = ncOfSoluticns + 1
elae
| Ty o i1l next fow
do i=1,8i28
feall secQuesn (lel_gquesns, zowdl, 1)
call sex{uesn (gasens, Towsl, i)
and da

e The Source tab shows the complete source surrounding one code location in the Data race
problem: A memory Write. Notice the source code corresponding to the Write code location is
highlighted.

0 The Disassembly tab shows low-level operations for the Write code location in the Data race
problem.

0 The Call Stack tab shows the complete call stack for the Write code location in the Data race
problem.
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2 Getting Started Tutorial: Analyzing Threading Errors

4 This region shows source, disassembly, and call stack information for another code location in
the Data race problem: A concurrent memory Write.

Use the /E’ icons to expand/collapse source, disassembly, and call stack information for each
code location region in the Data race problem.

Access More Information on Interpreting and Resolving Problems

1. Right-click anywhere in the Source or Disassembly tab.

2. Choose Explain Problem to display the Intel Inspector XE Help information for the Data race problem
type.

Key Terms

e (Code location
e Problem

Resolve Issue

I~

& To fix the detected threading error:

e Investigate the issue.
e Access an editor directly from the Intel Inspector XE.
e Change the source code.

Investigate the Issue

Scroll to near line 146. The embedded commenting in the nqueens threading.£90 sample file identifies
how to fix the Data race problem: Uncomment the atomic on the nrOfSolutions variable.

Access an Editor
Double-click near line 146 to open the nqueens threading.£90 source file in an editor:
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nqueens_threading.f90 =

%2 (Global Scope) | .
! wertical attacks
14 (lel gueens(i) == cal) return
if (queens(i) == col) return
! diagonal attacks
!1if (abs{lcl_gqueens(i)-col) == {(row-i}) return
if (abs{queens{i)-col) == (row-i}}) return
end do

! column is ok, set the gueen
1lcl_gqueens{row) = col
queens{row) = col

if (row == size) then
luncomsent the atomic to fix a race condition on the nrOfSolutions variable
LIg0MP ATOMIC
nrofSolutions = nrofSolutions + 1
elsﬂ
! try to fill next row
do i=1,size
fcall setQueen (lcl queens, rowsl, i)
call setQueen (queens, rowsl, 1)
end do
end if
end subroutine SetQueen

! Main solver routine
-lsubroutine solve (queens)
implicit none
integer, intent(inout) :: queens(:)
integer =: i E

130MP PARALLEL DO
do i=1,size
! try all positions in first row
call SetQueen (queens, 1, i)
end do

end subroutine solve

end program nQueens

0% - 4 LIl ¥

Change the Source Code

1. Uncomment ! ! SOMP ATOMIC.

2. Save your edits (automatic if you are using the Visual Studio* IDE editor).
3. Click the result tab to return to the Sources window.

NOTE The Sources window data is unchanged because it is a snapshot of the source code at the time
of analysis.

4. Click the Summary button to display the Summary window.

Key Terms
Code location
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2 Getting Started Tutorial: Analyzing Threading Errors

Investigate Problem Using Interactive Debugging

m If you are using the Visual Studio* IDE, you can investigate a problem more deeply with an interactive
debugging session during analysis.

e Launch an interactive debugging session.
e Experiment using standard debugging commands.
e Stop the analysis and interactive debugging session.

Launch an Interactive Debugging Session

In the Problems pane on the Summary window, right-click the data row for the Data race problem set
with three Data race problems (at lines 135, 138, and 143) to display a context menu, then choose Debug
this problem to:

e Launch a new analysis, of the same type, optimized to detect only the Data race problems in this
problem set.

e Halt application execution and open a debugging session when the Intel Inspector XE detects the first
occurrence of the Data race problems.

NOTE If the Intel Inspector XE tells you to rebuild the project, click the OK button to continue using
the original build.
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nque:M_{hering.‘Fgﬂ XMI LR T

“1% (Global 5cope)

I 4 statememts fn]l.—ming these which use the “gqueens”™ array.
lintegsr =: lr.'._qJEem.iJ'.*—:hundlf::.:r.--:"'ls..d:rwl:l]

! Hake copy of queens array

'1cl_queens = gueens

do i=]1;rom-1
| wvertical attacks
1if (lel_queens(i) == col) return
if (queens(i) == col) return
! diagonal attacks
1if (abs({lcl_queens(i}-col) == (row-i}) return
if (abs(queens(i)-col) == (row-1i}) return
end da
| column is ok, set the queen
!lel_queens(row) = col
queens{row) = cal

if (row == size) then
uncomment the atomic to fix a race conditien on the nrofSolut

IE§0MP ATOMIC
nrdfSolutions = nrOfSolutions + 1
else
I try to fL11 next row
do iml,size
Mm% -
Autos » [
Mame Value Type 1

STty B Locals M Watch 1

% Problem Details 5]

L1

ions variable

]

L 4
£ Source @ Intel Inspector 4 Disable Breakpaint B3 Re-snable Breakpoints § |

Data race at data location 0x167912B0 for threads OMP Worker Thread 81 and
60

Description & Source Function Module

# Allocation 5i... [ nqueens_threading ... NQUEENS threading_igsues, e
¥ Read I ngueens_threading .. NQUEENS jp_SETOUE... threading_issues.exe
+\Write [F ngqueens_threading ... NQUEENS ip SETQUE... threading itsues.exe
H Prable... \ Call 5ta.. - E!.-eal::p - T N Immedi... B l:::lur_r_'lu1

Intel Inspector XE launches a new analysis, r001ti2, with the same configuration settings used

to create the r000ti2 result, except the analysis is optimized to detect only the Data race

a debugging session when it detects the first

occurrence of the Data race problems. In the Visual Studio* IDE, this problem breakpoint is

1

problems in the selected problem set.
2 Intel Inspector XE halts execution and opens

indicated by a yellow arrow at the appropriate source line.
3

The Problem Details pane appears when the problem breakpoint occurs. Use this pane to

view the same problem details found in the Intel Inspector XE result, duplicated within the
debugger workspace for convenient referencing while you examine the application state for

debugging purposes.

Experiment Using Standard Debugging Commands
During the interactive debugging session, use the normal

Visual Studio* debugger actions to examine

memory and other state information, set code breakpoints, and continue execution. Only the use of data

breakpoints is not supported.

Stop the Analysis and Interactive Debugging Session

When you are finished experimenting in the debugger workspace, stop both the interactive debugging

session and the analysis:
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2 Getting Started Tutorial: Analyzing Threading Errors

1. Click the Intel Inspector button on the Problem Details pane to display the still-running ro01ti2
result.

2. Click the Stop button on the Intel Inspector XE Command toolbar.
3. Click the Collection Log button for the new r001ti2 result to wait for finalization to complete.

When finalization is complete, the Intel Inspector XE displays a Summary window for the new r001ti2
result that contains only the selected Data race problems in the selected problem set.

ﬂ TIP Intel Inspector XE automatically adjusts the debugging session analysis to return to the Data
race problem more quickly; however the analysis adjustments do not correspond to individual
problem types. Consequently, the Intel Inspector XE may detect and report additional problems, but it
will break only for the Data race problem.

Key Terms

e Problem
e Problem breakpoint
e Problem set

Rebuild and Rerun Analysis

To check if your edits resolved the problems in the Data race problem set:

e Rebuild the application with your edited source code.
e Rerun the analysis.

Rebuild the Application
If you are using the Visual Studio* IDE:

1. Choose Build > Clean Solution.
2. Choose Build > Rebuild Solution.

If you are using the Standalone Intel Inspector XE GUI:

1. In a command prompt window, change directory to the nqueens fortran directory.
2. Type devenv nqueens fortran.sln /Clean.

3. Type devenv nqueens fortran.sln /Build.

NOTE Do not be concerned if you see a Build: 2 succeeded, 1 failed message because of static
analysis build errors.

Rerun the Analysis

To run another analysis of the same analysis type:
e From the Visual Studio* menu, choose Tools > Intel Inspector XE 2013 > Threading Error
Analysis / Detect Deadlocks and Data Races.

¢ From the Standalone Intel Inspector XE GUI menu, choose File > Threading Error Analysis / Detect
Deadlocks and Data Races.

The Summary window automatically displays after analysis (both collection and finalization) completes
successfully:
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File View Help
PH s BT bW

00052 | r00IM2 | POOZER v

¥ Detect Deadlocks and Data Races Intel Inspector XE 2013
B Targel A s Type | MW
Problems

D L Problem  Sources Maodiubes State
o ® Data race  ngueens_threading 90 threading_issuetee ™ Mot foed 1 emds)

Dt race 1 iternds)
| Sowrce

ngueens_threading 50 1 ternds)

Hedube

theeading_issuesexe 1 iternds)

Skate

Mot fed 1 ternds)

1100 1ef7 0 [a0] i

Dezcnption Source Function Maodule
Wite nqueens_threading fB20:143 MQUEENS sp_SETQUEEN threading_issues. eoe

j141l I calk

is ok, set che Qassn chreading ismees.sxe ! HOFEERS ip SEIQ =
14l tlel_gueens (Tow)

143 gueenairow] = col
Lad

145 if frow == migs) chen
ngqueens_threading 90:143 NQUEENS _sp_SETQUEEN threading issues. eoe

ok, set the gueen

Notice the Intel Inspector XE:

e Created a new result tab: r002ti2.
e Detects only one threading problem set.

Key Terms

Analysis
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Summary

I3 This tutorial demonstrated an end-to-end workflow you can ultimately apply to your own applications.

Step

Tutorial Recap

Key Tutorial Take-aways

1. Set up

If you used the Visual Studio* IDE:
You chose a project; verified the
project is set to produce the most
accurate and complete analysis
results; built and ensured the
application runs on your system
outside the Intel Inspector XE.

If you used the standalone GUI:
You built and ensured the
application runs on your system
outside the Intel Inspector XE, and
created a project to hold analysis
results.

Applications compiled and linked in debug
mode using the following options produce the
most accurate and complete analysis

results: /debug:full, /0d, /libs:d11l/
threads or 1ibs:dl1l/threads/dbglibs,
and /check:none.

2. Collect resuit

You chose an analysis type and ran
an analysis. During analysis, the
Intel Inspector XE:

e Ran the application, identified
errors that may need handling,
collected a result, and displayed
the result in a result tab.

e Added a pointer to the result in
the Solution Explorer (Visual
Studio* IDE) or Project
Navigator (standalone GUI).

¢ Intel Inspector XE offers preset analysis
types to help you control analysis scope
and cost. Widening analysis scope
maximizes the load on the system, and the
time and resources required to perform the
analysis.

e Run error analyses from the Tools menu
(Visual Studio* IDE), File menu
(Standalone Intel Inspector XE GUI),
toolbar, or command line using the
inspxe-cl command.

3. Investigate
result

You explored detected problems,
interpreted the result data,
accessed an editor directly from
the Intel Inspector XE, and
changed source code. You also
investigated a problem using
interactive debugging if you used
the Visual Studio* IDE.

e Key terms: A code location is a fact the
Intel Inspector XE observes at a source
code location. A problem is one or more
occurrences of a detected issue. A problem
set is a group of problems with a common
problem type and a shared code location
that might share a common solution.

e Think of the Problems pane on the
Summary window as a to-do list: Start at
the top and work your way down.

* Double-click a code location or problem on
the Summary window to navigate to the
Sources window. Click the Summary
button on the Sources window to return
to the Summary window.
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3 Getting Started Tutorial: Analyzing Threading Errors

Step Tutorial Recap Key Tutorial Take-aways

* Right-click various places on the
Summary or Sources window to display a
context menu, then choose Explain
Problem to access more information on
interpreting and resolving the problem.

e Double-click a code location on the
Sources window to open an editor.

¢ Right-click a problem, then choose Debug
This Problem to launch an interactive
debugging session (Visual Studio* IDE).

4. Check your You recompiled, relinked, and
work reinspected the application.

Next step: Prepare your own application(s) for analysis. Then use the Intel Inspector XE to find and fix
errors.
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Key Terms

The following terms are used throughout this tutorial.
analysis: A process during which the Intel Inspector XE performs collection and finalization.

code location: A fact the Intel Inspector XE observes at a source code location, such as a write code
location. Previously called an observation.

collection: A process during which the Intel Inspector XE executes an application, identifies issues that may
need handling, and collects those issues in a result.

false positive: A reported error that is not an error.

finalization: A process during which the Intel Inspector XE uses debug information from binary files to
convert symbol information into filenames and line numbers, performs duplicate elimination (if requested),
and forms problem sets.

problem: One or more occurrences of a detected issue, such as an uninitialized memory access. Multiple
occurrences have the same call stack but a different thread or timestamp. You can view information for a
problem as well as for each occurrence.

problem breakpoint: A breakpoint that halts execution when a memory or threading analysis detects a
problem. In the Visual Studio* debugger, a problem breakpoint is indicated by a yellow arrow at the source
line where execution halts.

problem set: A group of problems with a common problem type and a shared code location that might
share a common solution, such as a problem set resulting from deallocating an object too early during
program execution. You can view problem sets only after analysis is complete.

project: A compiled application; a collection of configurable attributes, including suppression rules and
search directories; and a container for analysis results.

result: A collection of issues that may need handling.

target: An application the Intel Inspector XE inspects for errors.

35



4 Getting Started Tutorial: Analyzing Threading Errors

36



	Getting Started Tutorial: Analyzing Threading Errors

	Legal Information
	Contents
	Overview
	Navigation Quick Start
	Analyzing Threading Errors
	Visual Studio* IDE: Choose Project and Build Application
	Standalone GUI:  	 Build Application and Create New Project
	Configure Analysis
	Run Analysis
	Choose Problem
	Interpret Result Data
	Resolve Issue
	Investigate Problem Using Interactive Debugging
	Rebuild and Rerun Analysis

	Summary
	Key Terms

