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はじめに 
 

このたびは、Source Insight をご利用いただき誠にありがとうございます。 

Source Insight は、C/C++、C#、Java プログラム、およびその他の言語を解析できる革新的な、プ

ロジェクト志向のプログラム コード エディター / ブラウザーです。ソース コードを解析し、作業中

に独自のシンボリック情報のデータベースをダイナミックに管理して、参照ツリー、クラス階層ダイア

グラム、コール ツリーを表示、役立つコンテキスト情報を自動的に提供します。 

大きなソースコードを理解する必要がある場合、Source Insight はソースコード ブラウザーとして効

果を存分に発揮します。 

このスタート ガイドでは初めてこの製品を使用される方を対象に、インストールの手順および製品

の起動方法について説明しています。 
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1. インストールおよびライセンス認証 

1.1. インストール手順 

 インストールに必要な環境 

Source Insight 4.0 をインストールするには、下記の環境が必要です。 

 OS: Windows Vista、7、8、10 

  Windows Server 2008、2012 

 プログラムのインストール 

ダウンロードした Source Insight 4.0 のインストールファイル (sourceinsight4xxx-setup.exe) をダブ

ルクリックします。 

画面の指示に従い、インストールを実行します。 

 

インストールが完了した画面で、[Launch the program] を選択して [Finish(完了)]ボタンをクリック

すると、Source Insight が起動し、 [Source Insight 4.0 License Management] ダイアログが表示され

ます。 
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1.2. ライセンス認証 

初めて Source Insight を起動する際、[License management (ライセンスの管理)] ウィンドウが表示

されます。そこで、シリアル番号を入力するか、新しい体験版のライセンスを開始するよう求められ

ます。体験版ライセンスは 30 日間実行できます。体験版のライセンスを使用する際、シリアル番号

は必要ありません。 

 

 

License Management でのライセンス認証(アクティベート) には、3つのオプションがあります。 

(1) Enter your purchased serial number to activate a license on this machine. 

このオプションは、製品を購入して受け取ったシリアル番号を入力し、オンラインでライセンス認証

(アクティベート) します。 選択すると、シリアル番号を入力する画面が表示され、次にユーザー情

報を入力する画面が表示されます。 

(2) Begin a 30-days Free Trial of Source Insight 

体験版をダウンロードした場合に、このオプションを選択して、オンラインで体験版のライセンス認

証をします。選択するとユーザー情報を入力する画面が表示されます。 

(3) Import a new license file. 

インターネット接続ができない場合、開発元にシリアル番号とユーザー情報を連絡するとオフライン

でライセンス認証ができるライセンス認証用の License file が提供されます。このライセンス ファイ

ルを受け取った場合に、このオプションを選択して、製品版または体験版をオフラインでアクティ

ベートできます。 ライセンス ファイルについて不明な場合は、弊社までご連絡ください。 

30 日間の体験版として、アクティベートします。 

ラインセス ファイルをインポートします。 

購入した v4.0 のシリアル番号を入力して、 

製品をアクティベートします。 
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アクティベーション画面では、下記のようにユーザー情報 (氏名、会社名、電子メール アドレス) 

を入力する画面が表示されます。電子メール アドレスはオプションですが、紛失した場合でもライ

センスを再取得できるので、強く推奨します。 

 

ライセンスを認証するとき、Source Insight はユーザーから提供された情報に加え、ハードウェアの

情報をセキュアな SSL 接続を介してライセンス システムに送信します。 それにより、Source 

Insight はライセンスをマシンと一致させることができます。 アクティベート後は、ライセンスを無効

にすることなく、ほとんどのハードウェアの変更を加えることができます。 Source Insight では、ユー

ザーのプライバシーを尊重し、第三者に対する情報の共有は行いません。 

Domain: sls.sourceinsight.com   (HTTPS ポート番号: 443) 

ライセンス認証および解除に関して、弊社 Web サイトに「よくあるご質問 (FAQ)」 ページをご用意

しておりますので、ご参照ください。 

ライセンス認証 （アクティベーション）に関連する FAQ:  

https://www.xlsoft.com/jp/products/sourceinsight/faq.html 

 

ライセンス認証のプロセスに関する問題やご質問がある場合は、開発元(info@sourceinsight.com)、

あるいは、弊社までご連絡ください。 

弊社のお問合せページ: https://www.xlsoft.com/jp/services/contact.html 

https://www.xlsoft.com/jp/products/sourceinsight/faq.html
mailto:info@sourceinsight.com
https://www.xlsoft.com/jp/services/contact.html
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2. プロジェクトの設定 

2.1. 外部シンボルのインポート 

[Import External Symbols （For all Project）(すべてのプロジェクト用の外部シンボル インポート)] 

ダイアログが表示されます。 

 

.NET アセンブリ、Java クラス、C/C++ ヘッダー ファイル、およびその他のソース ツリーなどの外

部ソースからのシンボル情報をインポートできます。 

このインポート処理は、メニューから選択することで、いつでも実行可能です。 キャンセルをクリック

して、この処理をスキップしてもかまいません。 

インポート処理が完了すると、新規にプロジェクトを作成するか確認する画面が表示されます。 
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2.2. プロジェクト 

 プロジェクトの機能 

Source Insight プロジェクトには、次のような重要な機能があります: 

 プロジェクトは、関連するファイルを論理的にグループ化します。 

 ファイルを開くとき、ドライブまたはディレクトリを指定する必要がありません。 

 Source Insight は、シンボル データベースを管理します。 このデータベースには、プロジェク

ト内のすべてのシンボル宣言および参照が含まれます。 シンボルデータベースは、インクリメ

ンタルに自動的に更新され、ファイルがソース管理システムなどの外部で変更されると、

Source Insight はそれらのファイルをプロジェクト シンボル データベースと自動的に同期さ

せます。 

 Source Insight は、コールツリー、参照ツリー、クラス階層などのシンボル関係をプロジェクトに

表示できます。 

 Source Insight は、参照インデックスを保持しているので、プロジェクト全体のシンボル参照を

高速に検索できます。 

 各プロジェクトは、それぞれ独自のセッション ワークスペースを持ちます。 プロジェクトが開か

れると、すべてのセッション状態が復元され、プロジェクトを閉じると開かれているファイルはす

べて閉じられ、ワークスペースは保存されます。 

 

カレント プロジェクト 

Source Insight のインスタンスを複数実行することができますが、各インスタンスは、一度に 1 つの

プロジェクトのみ開くことができ、それぞれ異なるプロジェクトを開くことができます。 

Source Insight は、シンボル宣言を検索するために、他のセカンダリ プロジェクトを開くことがありま

す。これらは、バックグラウンド プロジェクトであり、ユーザーは、オープンまたはクローズされている

ことを認識しません。 

このガイドでは、特に断りのない限り、プロジェクトを 1つ開いていると仮定します。 

 

プロジェクト ディレクトリ 

プロジェクトを作成するとき、プロジェクト用に 2つのディレクトリを指定する必要があります: 

 Project Data Directory (プロジェクト データ ディレクトリ) – これは Source Insight がプロジェ

クト データ ファイルを格納する場所です。たとえば、.siproj ファイルがここに格納されます。

デフォルトでは、プロジェクトは、Documents¥Source Insight 4.0¥Projects フォルダー内にプロ

ジェクト データ ディレクトリを作成します。 
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例 ：  C:¥Users¥John¥Documents¥Source Insight 4.0¥Projects¥MyProj フ ォ ル ダ ー に 

MyProj.siproj が保存されます。 

 Project Source Directory (プロジェクト ソース ディレクトリ) – これは通常、ローカル ソース 

リポジトリ ツリーのルートです。 これらの 2 つの別々のフォルダーを維持することで、Source 

Insight のデータをソース ファイルとは別に保存することができます。 

例: c:¥work¥proj1¥src フォルダーにソースコードのサブディレクトリを含むソースコードを含ま

れます。 

 

 プロジェクトの作成 

新規のプロジェクトを作成するには、[Project] - [New Project] を選択します。既存の Source 

Insight のプロジェクトを開くには、[Project] - [Open Project] を選択します。 

 

プロジェクト名とプロジェクトデータを保存する場所を指定します。 

 

プロジェクト データ ディレクトリは、信頼性およびパフォーマンスのためネットワーク上ではなく、

ローカルにすることを推奨します。 
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 プロジェクトの設定 

プロジェクトの設定コマンドでは、現在のプロジェクトを管理する様々なオプションを設定できます。

プロジェクトを開いていない場合、プロジェクト設定コマンドは、新しいプロジェクトに継承されるデ

フォルトのオプションを設定できます。 

プロジェクト設定は、プロジェクトデータ ファイルとともに保存されます。  

 

Conditional Parsing (条件付き解析) 

Conditions… 

現在のプロジェクトにのみ固有の条件を定義できます。 この条件は、現在のプロジェクトが開かれ

たときのみ有効で、プロジェクトに属しているファイルに対してのみ有効です。 

Project Source Directory 

これをプロジェクトのソース ツリーの 「ルート」 とみなします。 Source Insight がファイル名を表示

するとき、相対ディレクトリが表示されます。 このテキストボックスを空白にすると、Source Insight は、

メインプロジェクト ファイル (*.siproj) を作成した プロジェクトデータ ディレクトリを使用します。 

Project Backup Directory 
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ソースファイルのバックアップを保存する場所を指定します。デフォルトでは、プロジェクトフォル

ダー内に作成されます。 

Project Source Files 

Add and remove source files manually (手動でソースファイルを追加および削除) 

[Project] > [Add and Remove Files] を使用して、手動で追加されるファイルのみをプロジェクトに含

めます。 

Use a Master File List (マスターファイルリストを使用) 

Master File List (MFL)でリストされたすべてのファイルを含めます。 プロジェクトに手動でファイル

を追加および削除することもでき、その変更は、MFL に保存されます。 

Symbol Database Options 

このオプションは、プロジェクトのシンボル データベースに格納されているものに影響します。プロ

ジェクトにファイルを追加する前に、このオプションを選択する必要があります。プロジェクトを構築

した後にこのオプションを変更した場合、プロジェクトは再構築する必要があります。 

Quick browsing for member names (メンバー名のクイック参照) 

有効になっている場合は、名前の部分一致を実行するために、構造およびクラスメンバー名を入

力するだけです。ただし、シンボルインデックスサイズとメモリ使用量は、2 倍以上に増加する可能

性があります。このオプションは、主にオブジェクト指向言語を使用しているため、クラス名を入力す

ることなくメンバー関数と変数を見つけることができます。 

Quick browsing for symbol name fragments (シンボル名フラグメントのクイック参照) 

有効になっている場合は、名前の部分一致を実行するために、シンボル名の名前フラグメントを 1

つまたは 2 つだけ入力する必要があります。ただし、シンボルインデックスサイズとメモリ使用量は、

4 倍以上に増加する可能性があります。名前の断片を索引付けすることによって、記号の名前がど

の文字で始まるかわからなくても、名前断片の一致を使用して素早く記号を見つけることができま

す。 

プロジェクトが非常に大きい場合（数千ファイルまたは数十万を超えるシンボル）、このオプションを

オフにすると、メモリを少なくしてプロジェクトシンボルリストウィンドウを高速化してパフォーマンスを

向上させることができます。 

両方のチェックボックスをオフにすると、プロジェクトシンボルリストパネルのリストフィルタリングが単

純なプレフィックスマッチングに戻ります。ただし、各ソースウィンドウの左側のシンボルウィンドウと

プロジェクトウィンドウのファイルリストでは、名前フラグメントの参照が可能です。 
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 プロジェクトにファイルを追加 

プロジェクトを作成したら、次にプロジェクトにソースファイルを追加する必要があります。ファイルを

追加するには、いくつかの方法があります。 

新規のソースファイルを Source Insight で作成した場合、最初に保存するときに Source Insight は

現在のプロジェクトに追加するかどうかを確認します。 

すでにソースファイルが存在している場合、現在のプロジェクトにそれらを追加するには、[Add and 

Remove Project Files] を使用します。 

Windows エクスプローラーからファイルを Project File List パネルにドラッグすることでファイルを

追加することもできます。Project File List パネルでプロジェクトからファイルを削除することも可能で

す。 

[Add and Remove Project Files] ダイアログボックス 

 

File Name (ファイル名) 

このテキストボックスに追加または削除したファイルの名前を入力します。 

Directory List (ディレクトリ一覧) 

現在のドライブのディレクトリツリーを表示します。 
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File Name List (ファイル名一覧) 

現在選択されているディレクトリのファイル一覧です。すでにプロジェクトに含まれているファイルは

表示されません。 

Project Files List (プロジェクト ファイル一覧) 

プロジェクトに追加されたすべてのファイル一覧を表示します。 

Add (追加) 

プロジェクトに選択したファイルを追加します。 

Add All (すべて追加) 

Selects all the items in the File Name 一覧内のすべてのファイルを選択し、プロジェクトに追加しま

す。ディレクトリが含まれる場合、その中も追加されます。 

Add Tree (ツリーを追加) 

ソースツリー全体をプロジェクトに追加します。 

ディレクトリを選択した場合、ディレクトリツリー全体をプロジェクトに追加します。 

Remove Tree (ツリーを削除) 

ディレクトリを選択した場合、ディレクトリツリー内のすべてのファイルをプロジェクトから削除します。 

Show only known file types (既知のファイルタイプのみ表示) 

[Options] > [File Type Options] で定義されたファイルのみをファイルリストに含めます。さらに、 

"Include when adding to project" オプションが有効になっているファイルタイプのみ含まれます。 

有効になっていない場合、すべてのファイルタイプが表示されます。バイナリ ファイルではなくテキ

ストファイルのみを追加する必要があります。 

Remove File (ファイルを削除) 

プロジェクトファイルリストから選択したファイルを削除します。 

Remove All (すべて削除) 

プロジェクトからすべてのファイルを削除します。プロジェクトは空になります。 

Remove Special… (特別な削除) 

[Remove File (ファイル削除)] ダイアログが表示され、すべての *.h ファイルを削除するなどの、特

別な削除操作が可能になります。 

Add from list… (リストから追加) 

[Add File List (ファイルリストの追加)] ダイアログが表示され、プロジェクトに追加するファイルとディ

レクトリを含むテキストファイルを指定することができます。 
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3. Source Insight の機能 

3.1. バージョン 4.0 の新機能 

 新機能 

Source Insight 4.0 では、多数の新機能と機能強化がされております。以下は、主な新機能および

強化点です: 

 

 C/C++、 C#、 Java、 およびその他の言語の言語解析の強化。 

 Objective-C、 Python、 PHP、 XML、 および JSON ファイルをビルトインでサポート。 

 .NET アセンブリ、Java JAR ファイル、Include ファイルなどの外部ソースからシンボルをイン

ポート。 

 File Window タブがメイン ウィンドウの上部に表示されます。 

 コード ブロックを折りたたむことができ、位置と外観を制御できます。 

 ファイルとディレクトリの比較 (差分)。 

 C/C++ および C# などの中括弧の言語で動作する コード ビューティファイア(整形)。 

 Unicode サポート。 

(Source Insight 3.5 では、ASCII (Shift JIS) でしたが、v4.0 はデフォルトで Unicode (UTF-8) 

サポートし、プロジェクト、ファイルによってエンコードを変更できます。) 

 任意の識別子をクリックする時に参照ハイライトが、正しいスコープ内の参照を表示します。 

 パネルの新しいユーザー インターフェイスとユーザー定義のビジュアル テーマ。 

 新しい概要スクローラーは、通常のスクロールバーにように位置を示すだけでなく、ファイルの

鳥瞰図を提供します。 現在の関数の境界を表示し、長い関数内での位置を確認できます。 

 新しい強化された垂直スクロールバーは、スロールバー内でさらに詳細を表示します。 

 複数のウィンドウ レイアウトにより、すばやく切り替えることができます。 

 コード スニペット: 挿入するための再利用可能なコード テンプレートを定義でき、自動生成

されたプレースホルダー変数を含めることができます。 

 改良されたブックマーク: ブックマークは、永続的に格納され、近くの関数またはクラス名から

の行オフセットとして保存されます。各プロジェクトはそれぞれ独自のブックマーク  リストを

持っています。 

 改良されたリレーション ウィンドウ: 参照の検索がさらに高速になりました。新しいリレーション 

タイプ "calls and callers" が追加されました。これは、アウトラインまたはグラフで表示されます。
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グラフ ビューを Windows のクリップボードにコピーできます。 

 プロジェクトごとにバックアップ ファイルを維持し、バックアップ バージョンとの比較が簡単に

でき、現在のバージョンの古いバージョンを開くこともできます。 

 より良い正規表現: Perl 互換および複数行の表現をサポートします。 

 大規模プロジェクトのサポート向上: 非常に大きなプロジェクトがメモリ空間にフィットするよう

に仮想メモリの利用が改善されました。古いバージョンでは、大量のシンボル用にプロジェクト 

インデックス ファイル上で読み込みエラーを起こしたり、プロジェクトの破損を引き起こしまし

た。これが解消されました。 

 マスター ファイル リスト (MFL) を使用することで、複数のユーザーおよびマシンでのプロ

ジェクト管理が簡単になりました。プロジェクトは、ソース コード レポジトリの一部として、他の

ユーザーと共有することができる MFL を持つことができます。これはシンプルなテキスト ファ

イルでプロジェクトのすべてのファイル(およびディレクトリ)のリストです。 

 プロジェクト ソースを HTML サイトにエクスポートできます。すべてのファイルを  Source 

Insight で表示されるほとんど同じ構文形式を含む HTML バージョンにエクスポートするた

めにこれを利用できます。これは、web ブラウザーでプロジェクト ソース コードを参照するた

めに使用できる Web サイトを構築します。 

 ブラウザー モード: Source Insight は、読み取り専用のコード ブラウザーとして動作します。

単に、識別子をクリックすることで、Web ブラウザーのように定義にジャンプします。 

 各ソース ファイル ウィンドウにアタッチしているシンボル ウィンドウ ペインは、折りたたみ可

能なアウトライン ビューを持ちます。 

 XML ファイルですべての設定を保持する新しい構成システム。 

 その他多数の改良。 

 

 ファイル形式の変更 

Source Insight が作成および管理したいくつかのデータファイルが ver 4で変更されました。 

 プロジェクトファイル - メインプロジェクトファイルの新しい拡張子は、.siproj です。 すべての

プロジェクトデータファイル形式がバージョン 3 から変更されました。Ver 3 プロジェクトは引き

続き開くことができますが、新しい形式に変換されます。 

 Configuration Files (構成ファイル) - すべての設定が XMLファイルに保存されるようになりま

した。 構成が大きく変更されたため、ver 3.5の構成ファイルはサポートされていません。 

Options > Load Configuration を選択し、古い Global.CF3 ファイルを指定して、読み込んで、

新しいファイル形式に変換することができます。 

 ワークスペースファイル - 新しい拡張子は、.siworkです。 ver 3 と互換性がありません。 

 リカバリファイル - 新しい拡張子は、.si_recoveryです。 
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 ファイル ストレージ 

Source Insight 4 は、<HOMEDRIVE>/users/<user-name>/Documents/Source Insight 4.0 内にほと

んどのデータを格納します。 

"Documents/Source Insight 4.0" フォルダー内のフォルダーは以下の通りです: 

フォルダー名 説明 

Backup 非プロジェクトファイル用にファイルバックを保存します。 

Bookmarks すべてのプロジェクトで使用される "グローバル" ブックマーク 

Clips クリップ ステレージ。Clip 機能を参照してください。 

Logs ログ ファイル。 Options > Preferences: General : Logging... で制御され

ます。 

Projects 各プロジェクト ファイルは、このフォルダー内にデータフォルダーがあ

ります。 

Settings 構成設定、テーマ、レイアウト。 

Snippets コードスニペット 

c.tom file C/C++ プリプロセッサ トークン マクロ。 

FileAlias.txt file 拡張子なしのファイル名を ファイル タイプにマップします。 
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3.2. Source Insight の機能概要 

Source Insight には、次のような機能が含まれています。 

 コール グラフとコール ツリー ダイアグラム  

 状況に応じてダイナミックにソースを分類  

 ファイルごとにシンボル ウィンドウを表示  

 コンテキスト ウィンドウに宣言を自動的に表示  

 構文フォーマット - 構文の色分け など  

 状況に応じて名前を変更  

 参照を素早く検索  

 混在言語の編集  

 コード ベースでインターネット検索のようなキーワード検索  

 シンボルの自動補完  

 すべてのシンボルとファイルに素早くアクセス  

 チーム プログラミングのサポート  

 リンクやコンパイラ エラーへのハイパー ソース リンク  

 プロジェクト全体の高速な検索と置換  

 複数のビューで構成されたプロジェクト ウィンドウ  

 外部コンパイラおよびツールとの統合  

 クリップボードと定型コード格納用のクリップ ウィンドウ  

 2 段階の行改訂マークと選択的な行の復元  

 ドキュメントの種類および言語を拡張可能  

 クラッシュ リカバリによりフルタイムの保護を実現  

 カスタマイズ可能なメニューとキーボード  

 リモート ターミナル サーバー セッションの特別なサポート  

 フル機能のエディター  

 ドラッグ アンド ドロップ編集  

詳細は、オンラインヘルプまたはユーザーズガイドをご参照ください。 
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3.3. メイン ウィンドウ 

Source Insight のメイン画面は、上部にメイン ツールバーが表示され、シンボル ウィンドウ、ソース

ファイル ウィンドウ、リレーション ウィンドウ、コンテキスト ウィンドウが表示されます。 

 

 

 

 

 

 

 

 

  

メインメニューおよびツールバー 

各ファイルで定義されたシンボルを 

表示する シンボル ウィンドウ 
編集および表示用の 

ソースファイル ウィンドウ 

ステータスバー クリックまたは入力中に宣言やその他の情報を

自動的に表示する コンテキスト ウィンドウ 

参照、コールツリー、その他の関係を表示する 

リレーション ウィンドウ 
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3.4. リレーション ウィンドウ 

リレーション ウィンドウは、シンボル間の関係を示す Source Insight の革新的な機能です。バック

グラウンドで動作し、ユーザーが選択したシンボルを追跡します。クラス階層、コール ツリー、参照

ツリー、その他を参照できます。 

リレーション ウィンドウの利点は、何も特別なことを行う必要がないことです。作業中はバックグラウ

ンドで動作していますが、必要なときに呼び出すことができます。 

リレーション ウィンドウは、グラフィカルまたはアウトライン形式で表示することができます。複数のリ

レーション ウィンドウを開いて、異なる種類の情報を表示することもできます。 

 

 

コールツリーの表示 
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ダイナミックな関係表示で、ソース コードをわかりやすく表示 

 

リレーション ウィンドウで間接参照を含む参照情報を表示 

 

コールグラフの表示 



 

3. Source Insight の機能  

 

19 Source Insight 4.0 スタート ガイド 

 

19 

 

リレーション ウィンドウで派生クラスを表示 
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3.5. リレーション ウィンドウの操作 

リレーション ウィンドウの表示内容は、ソースコード行のカーソル位置、選択範囲によりダイナミック

に変化します。 

リレーション ウィンドウを表示するには、[View] – [Panels] - [Relation Window] を選択し、メニュー

項目の左にチェックマークが付いた状態にします。 

 

 

Source Insight のメインウィンドウおよびリレーション ウィンドウなどにあるツールバー、または各ウィ

ンドウを右クリックして表示される コンテキスト メニューを選択すると、新規のリレーション ウィンド

ウを表示し複数のリレーション ウィンドウを表示したり、リレーション画面のダイナミックな変更をロッ

ク(停止)することもできます。 
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定義できます。一度定義したら、他のコマンドと同様に使用できます。メニューに割り当て、キースト

ロークの割り当てができます。 

カスタムコマンドは、コンパイルを起動するときに役に立ちます。コンパイラや make プログラムを実

行するカスタムコマンドを定義すると、コンパイラ エラーメッセージをキャプチャー、エラーの分析、

間違ったソースコードへのリンクを自動的に取得できます。 

カスタムコマンドを使って、テキスト フィルタを実装することもできます。たとえば、ソート(並べ替え) 

フィルタを実行し、現在の選択箇所に上書きで戻すカスタム コマンドを定義できます。 
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4. V4.0での注意 

4.1. 日本語環境での制限 

Source Insight は、英語版ソフトウェアをそのまま販売しています。現在、日本語環境での使用に

おいて一部制限が報告されていますが、開発元では日本語環境での問題に迅速に対応していき

ますので、弊社 Web ページを定期的にご参照ください。 

 Shift JIS のソース 

以前のバージョンでは、ASCII (Shift JIS) の対応でしたが、Source Insight 4.0 からは、Unicode 

対応になりました。デフォルトは Windows システムのエンコードと同じで  UTF-8 になります。 

Shift JIS でエンコードされたソース ファイル、テキスト ファイルは文字化けして表示されるので、

事前にプロジェクトのエンコードを指定して読み込んでください。 

[Options] - [Preferences] を選択し、[Files] タブを開いて、"Default encoding" のドロップダウン 

リストで "UTF-8" から "Japanese Shift-JIS CP:932" に変更してください。 

既にファイルを開いている場合は、[File] - [Reload As Encoding] を選択して、特定のエンコードで

読み込み直すことができます。 

            

[Options] - [Preferences] > [Files]                  [File] - [Reload As Encoding] 
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4.2. 旧バージョンとの互換性 

 旧バージョンの Source Insight との互換性 

V3.5などの以前バージョンを使用していた場合は、このセクションを是非ご一読ください。 

Source Insight v4 と v3 は、同じマシンで利用できます。それぞれ別のファイルと Windows レジ

ストリ設定を使用するため、競合しません。プロジェクトのデータファイル形式だけでなく、ファイル

の拡張子も異なります。 

古い v3.x のプロジェクトを開くには、[Project] > [Open Project...] を選択し、[Browse] ボタンをク

リックし、古い .PR ファイルを探します。 古いプロジェクト ファイルは、コピーされて新しい形式に

変換されます。元の v3.x のプロジェクトは変更されず、そのまま残ります。 

バージョン 3.5 の古い構成ファイル(configuration ファイル (*.CF3)) をインポートすることができ

ます。 Options > Load Configuration を選択し、古い Global.CF3 ファイルを指定します。そのファ

イルを開くと、スタイル、カラー、フォント、キー組み合わせのオプションが表示されます。通常、

バージョン 3.x 構成ファイルは、以下の場所に格納されています: 

C:¥users¥<your login name>¥Documents¥Source Insight¥Settings¥Global.CF3 

C: は、システム ドライブで、<your login name> はユーザーアカウント名です。 

 

 v3.x からの重要な変更 

プログラムを理解しやすくするため、いくつかの移動または名称変更がされています。 

 "Document Options" は、File Type Options に名称変更されました。 すべてのファイルタイ

プ固有のオプションが含まれます。  たとえば、"C/C++ Files" という名前が含まれます。 

"Document Type" という用語は、"File Type" に置き換えられました。 

 C および C++ ファイル タイプは、"C/C++ Source File" にマージされました。 

 "Draft View" を "Mono Font View" に、"symbol syllables" を "name fragments" に変更。 

 ドッキング可能/フローティングウィンドウはパネルと呼ばれるようになりました。 Context およ

び Relation ウィンドウの他に、FTP ブラウザー、ウィンドウリスト、スニペット、ブックマーク、ディ

レクトリ比較、ファイル比較などの新しいパネルがいくつかあります。 

 プロジェクトファイル - メインプロジェクトファイルの新しい拡張子は、.siproj です。すべての

データファイル形式が v3 から変更されました。 v3 プロジェクトは引き続き開くことができます

が、新しい形式に変換されます。 

 プロジェクト シンボルパスのアイデアは、[プロジェクト]> [外部シンボルのインポート]に置き換

えられました。 この機能を使用すると、ヘッダーファイル、.NET アセンブリ、Java jar ファイル

などの外部ソースからシンボルをインポートできます。 インポートするたびに、Source Insight

は特別な「インポート」プロジェクトを作成します。 
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 プロジェクト設定に "バックアップディレクトリ" オプションが追加されました。 デフォルトでは、

各プロジェクトはプロジェクト フォルダーの下に独自のバックアップフォルダーを作成します。 

 すべてのプロジェクトが同じ設定を共有します。 ただし、構成ファイルシステムには、プロジェ

クト固有の構成パーツについて柔軟性があります。   
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5. お問い合せ 

 テクニカル サポートへのお問い合わせ 

エクセルソフト株式会社ではテクニカル サポートを下記のお問い合わせ窓口より承っております。 

https://www.xlsoft.com/jp/services/xl_form.html 

 

 

 製品のお問い合わせ 

エクセルソフト株式会社 

〒108-0073 東京都港区三田 3丁目 9番 9号 森伝ビル 6階 

Tel: 03-5440-7875  

Fax: 03-5440-7876 

https://www.xlsoft.com 

E-Mail : xlsoftkk@xlsoft.com 

 

 

https://www.xlsoft.com/jp/services/xl_form.html
https://www.xlsoft.com/
mailto:xlsoftkk@xlsoft.com

